Údaje ROEP

Kontrola a oprava vstupných údajov ROEP

Obsah

1. ÚČEL APLIKÁCIE
2. FUNKCIONALITA APLIKÁCIE
2.1. Načítanie a kontrola údajov písomnej časti
2.2. Načítanie a kontrola údajov grafickej časti
2.3. Kontrola zapísateľnosti údajov do katastra nehnuteľností
2.4. Príprava údajov na zápis do ISKN
2.5. Oprava súboru údajov písomnej časti
3. ADRESÁRE A SÚBORY APLIKÁCIE
4. ZÁLOHOVANIE SÚBOROV
5. INŠTALÁCIA APLIKÁCIE
6. PRÁCA S APLIKÁCIOU
6.1. Spustenie aplikácie
6.2. Riadenie aplikácie
6.3. Administrácia
6.3.1. Výber katastrálneho územia
6.3.2. Aktívne katastrálne územia
6.3.3. Parametre spracovania KU
6.4. Načítanie a kontrola súboru písomnej časti ROEP
6.5. Načítanie a kontrola súboru grafickej časti ROEP
6.6. Kontrola zapísateľnosti
6.6.1. Kontrola údajovej skupiny vydržané parcely
6.7. Príprava údajov na zápis do ISKN
6.7.1. Voľba výmer pre E
6.7.2. Obnova LV
6.7.3. Obnova E parciel
6.7.4. Povolenie zápisu vydržaných parciel, ktoré nie sú predmetom konania
6.7.5. Povolenie spracovania doterajších parciel, ktoré sú zapísané na liste vlastníctva
6.8. Úprava súboru FÚVI
6.9. Vytvorenie katastrálnych súborov DBF/FPT z FÚVI
7. FORMULÁRE ÚDAJOV SPRACOVANIA
7.1. Zistené chyby
7.2. Evidencia prijatia
7.3. Údaje ROEP - nehnuteľnosti
7.4. Údaje ROEP - účastníci
7.5. Údaje katastra nehnuteľností
7.5.1. Parcely registra C
7.5.2. Parcely registra E
7.5.3. Vlastníci
8. TLAČOVÉ VÝSTUPY
8.1. Chyby pri kontrole a spracovaní
8.2. Početnosť chýb
8.3. Evidencia prijatia
8.4. Číselník chýb
8.5. Parcely zapísané na liste vlastníctva
8.6. Parcely účastníka
8.7. Parcely s napadnutými vlastníckymi vzťahmi
9. UKONČENIE APLIKÁCIE


Administrácia

Aministrácia zahŕňa:
- výber katastrálneho územia, ktoré sa vyberá pomocou formulára Výber katastrálneho územia a Aktívne katastrálne územia.
- Parametre spracovania KU, ktoré sa zadávajú pomocou formulára Parametre spracovania KU.

Všetky formuláre sa vyvolávajú kliknutím na rovnomenné časti menu Administrácia, ako to znázorňuje nasledujúci obrázok:


Formulár chyby pri kontrole písomnej časti

Formulár Zistené chyby

V tomto formulári je možné prehliadať chyby, ktoré sa zistia pri kontrole a spracovaní údajov ROEP. Formulár sa vyvoláva z menu Prehliadanie údajov:

Po kliknutí na riadok Chyby sa zobrazí formulár:

V ľavom hornom rohu sú umiestnené navigačné tlačítka, pomocou ktorých sa postupne zobrazujú záznamy v chybovom súbore. Pozícia v súbore je vidieť v údaji Záznam. Chybu je možné vyhľadať podľa jej poradového čísla napísaním tohoto čísla do pola s názvom Poradie chyby a kliknutím na tlačítko [image] .
V poli Kód je číselný kód chyby, vedľa neho údaj, či je chyba prevzateľná, alebo neprevzateľná. V poli Chyba je popis chyby, v poli Popis je jej širší popis.
V rámčeku s názvom Chyby je voľba, chyby ktorej etapy sa majú zobraziť. Prístupné sú len tie voľby, ktorých chyby sa nachádzajú v súbore chýb. Po vyvolaní formulára sa zobrazia chyby tej etapy, ktorá sa spracovávala naposledy. Ak sa ale pri kontrole žiadne chyby nezistili, tak v tomto formulári o tom nebudú žiadne údaje, ako prebehla kontrola je možné zistiť vo formulári Evidencia prijatia

V údajoch ROEP podľa MN z júla 2006 (FÚVI verzie 5.0 05/06.) sa súbory KN.VGI kontrolujú v časti A a ostatné súbory (vrátane príp. aj súborov KN.VGI) v časti B - bližší popis viď. Načítanie a kontrola súboru grafickej časti ROEP. Ak sa vykonala kontrola len KN.VGI v časti A, tak sa vo formulári namiesto textu Chyby 2. etapy zobrazí text Chyby časti A.

Ak sa v prípade údajov podľa MN z júla 2006 súbory VGI kontrolovali v časti A aj v časti B. tak sa vo formulári namiesto textu Chyby 2. etapy zobrazí text a možnosť voľby podľa nasledujúceho obrázku:

Ak je voľba chýb kontroly súborov VGI zakliknutá, tak sa pri prepínaní medzi voľbami zobrazia chyby zodpovedajúce vybratej voľbe, t.j. buď chyby pri kontrole súborov KN.VGI v časti A, alebo kontrole súborov VGI v časti B. .

Ak sa vo formulári má zobraziť len jeden druh chyby, tak sa k tomu použije časť formulára Kód chyby. Po zápise kódu chyby a kliknutí na prepínač sa zobrazia dané chyby. Po vypnutí prepínača opätovným kliknutím sa zobrazia tie chyby, ktoré sa zobrazia pri vyvolaní formulára. Ak sa majú zobraziť chyby iného udaného kódu, tak treba prepínač napred vypnúť a po zápise kódu chyby znova zapnúť.

Ak sa zobrazujú chyby 3. etapy - kontroly zapísateľnosti - tak je možné zvoliť, či sa majú zobraziť aj chyby, ktoré sa zobrazia vo formulároch 4. etapy, alebo sa tieto chyby zobraziť nemajú. V 4. etape - ktorá sa v tejo aplikácii nevykonáva - sa určí postup pre zápis do ISKN v prípade chýb určitého typu, preto tieto chyby nevyžadujú úpravu vstupných údajov spracovania:

Pri kontrole jednotlivých etáp sa vždy zo súboru chýb vymažú chyby tej istej etapy v predchádzajúcej kontrole. Chyby je možné vytlačiť v zostave Chyby pri kontrole a spracovaní.

Po kliknutí na tlačítko Riadok sa zobrazí súbor, ktorý sa kontroloval a kurzor sa nastaví na riadok, ktorého sa chyba týka. Počas prvého použitia tohoto zobrazenia ale treba použitím pravého tlačitka vyvolať miestnu ponuku menu a tam kliknúť na riadok Properties. Zobrazí sa okno:

kde treba kliknutím nastaviť voľby:

- Word wrap: zrušiť
- Save preferences: nastaviť
- Aply to .TXT files: nastaviť

Po kliknutí na OK, ukončení formulára editora a jeho opätovným vyvolaním sa bude kurzor už nastavovať na riadok, ktorý je uvedený v poli vedľa tlačítka Riadok.


Evidencia prijatia

V tomto formulári je možné prehliadať údaje o kontrole súborov písomnej časti ROEP. Formulár sa vyvoláva z menu Udaje:

Po kliknutí na riadok Evidencia prijatia sa zobrazí formulár:

V ľavom hornom rohu sú umiestnené navigačné tlačíttka, pomocou ktorých sa postupne zobrazujú záznamy v súbore s údajmi evidencie. Pozícia v súbore je vidieť v údaji Záznam.
V ostatných poliach formulára sú údaje kontroly súborov zodpovedajúce textu uvedenému pred poliami.


Formuláre

Formuláre údajov o účastníkoch a parcelách

V tejto časti sa bude hovoriť len o tých formulároch, ktoré sa vyvolávajú z menu Udaje:

V týchto formulároch je možné zobraziť údaje účastníkov a parciel vrátane chýb a evidencie kontroly písomnej časti ROEP, ako aj meniť údaje o účastníkoch.
Okrem týchto formulárov sa vyvolávajú ďalšie z menu Administrácia a používa sa ešte niekoľko ďalších, ktorými sa zadávajú rôzne parametre spracovania, tieto sa zobrazujú v závislosti od konkrétneho spracovania.

Vo formulároch, kde sa dáta zobrazujú vo forme tabuľky (mriežky), je možné meniť šírku stĺpcov umiestnením kurzora myši so stlačeným ľavým tlačítkom do hranice medzi názvami stĺpcov a jeho ťahaním vpravo, alebo vľavo, ako znázorňuje nasledujúci obrázok:

Vzájomnú polohu stĺpcov tabuľky je možné zmeniť umiestnením kurzora myši so stlačeným ľavým tlačítkom na názov stĺpca a jeho ťahaním vpravo, alebo vľavo, ako znázorňuje nasledujúci obrázok:

Po ukončení formulára a jeho novom vyvolaní sa ale tabuľka zobrazí v jej základnej podobe.


Popis funkcionality

2. Funkcionalita aplikácie

Základnú funkčnosť programu je možné rozdeliť do piatich etáp:
- 2.1. načítanie a kontrola údajov písomnej časti
- 2.2. načítanie a kontrola údajov grafickej časti
- 2.3. kontrola zapísateľnosti údajov do katastra nehnuteľností
- 2.4. príprava údajov na zápis do ISKN
- 2.5. oprava súboru údajov písomnej časti

2.1. Načítanie a kontrola údajov písomnej časti

Vstupnými údajmi pre túto etapu sú súbory FÚVI. Údaje sa môžu nachádzať vo viacerých súboroch, tieto sa postupne načítavajú a ich údaje sa pridávajú k dovtedy načítaným údajom. Údaje prechádzajú prvotnými kontrolami, ktoré sú stanovené v Metodickom návode na spracovanie registra obnovenej evidencie pozemkov v prílohe č. 3.

2.2. Načítanie a kontrola údajov grafickej časti

Vstupnými údajmi pre túto etapu sú súbory VGI.

Údaje prechádzajú prvotnými kontrolami, ktoré sú stanovené v Metodickom návode na spracovanie registra obnovenej evidencie pozemkov v prílohe č. 4.

2.3. Kontrola zapísateľnosti údajov do katastra nehnuteľností

V tejto etape sa kontroluje súlad údajov písomnej a grafickej časti vstupných údajov s údajmi katastra nehnuteľností. Táto časť sa môže vykonať len vtedy, ak bola kontrola v 1. a 2. etape bez neprevzateľných chýb, pričom sa kontroluje, či sa 2. etapa vykonala až po 1. etape.

2.4. Príprava údajov na zápis do ISKN

V tejto etape je možné v nasledujúcich piatich formulároch určiť spôsob spracovania v poslednej etape - zápise ROEP do ISKN. Spôsob spracovania sa v tejto etape určuje len v aplikáciách WROEP/WROEP5. V aplikácii ROEPDAT je zahrnutá len preto, aby sa umožnil prehľad o výsledkoch kontroly zapísateľnosti.

Voľba výmer pre E

Ak sa v údajoch ROEP líši písomná a grafická výmera parcely UO o viac, ako o povolenú odchýlku, tak sa v tomto formulári volí výmera, ktorá sa do ISKN zapíše.

Obnova listov vlastníctva

V tomto formulári sa určuje spôsob spracovania, ak sa vyskytne chyba vo vlastníckych vzťahoch parciel predmetu konania vedených v ISKN na LV.

Obnova E parciel

V tomto formulári sa určujú hodnoty na zápis do ISKN, ak sa zistil nesúlad výmery, druhu pozemku alebo umiestnenia parcely v ROEP a ISKN.

Povolenie zápisu vydržaných parciel, ktoré nie sú predmetom konania

V tomto formulári sa povoluje zápis takýchto parciel do ISKN, keďže z údajov ROEP nie je možné zistiť, či parcela nie je predmetom konania v dôsledku chyby údajov, alebo je to parcela, ktorá sa nemá zapísať na list vlastníctva.

Povolenie spracovania doterajších parciel, ktoré sú zapísané na liste vlastníctva

Doterajšia parcela, ktorá sa celá, alebo čiastočne vydrží by nemala byť zapísaná na liste vlastníctva. Ak je doterajšia parcela zapísaná na liste vlastníctva, tak sa jej spracovanie vo vydržaní musí povoliť v tomto formulári

2.5. Oprava súboru údajov písomnej časti

V tejto etape je možné opravovať súbory písomnej časti. Aplikácia nastaví riadok súboru FÚVI, v ktorom sa zistila chyba pri kontrole v 1. alebo 3. etape.


Inštalácia aplikácie

Inštalácia aplikácie sa štartuje dvojitým kliknutím na program webapp.exe. Po odštartovaní inštalácie sa objaví úvodné okno:

Pokračuje sa kliknutím na tlačítko [image] , objaví sa nasledujúce okno:.

Po vyplnení údajov pre meno a organizáciu a kliknutí na tlačítko [image] sa objaví ďalšie okno:.

kde sa tlačítkom [image] potvrdia informácie, ktoré sa zadali v predchádajúcom okne, alebo použitím tlačítka [image] je ich možné zmeniť. Inštalácia pokračuje oknom:.

V tomto okne je možné tlačítkom [image] zmeniť adresár , kam sa aplikácia nainštaluje. Kliknutím na [image] inštalácia pokračuje oknom:.

,

kde je možné tlačítkom [image] znova zmeniť adresár, kam sa aplikácia nainštaluje. Inštalácia pokračuje použitím tlačítka:

Nasledujúce okno umožňuje umiestniť program v ponuke Štart do zvolenej skupiny programov:

Po kliknutí na tlačítko Continue sa objaví záverečné okno inštalovania, ktoré informuje o úspechu inštalácie:.


Zálohovanie súborov

Kontrola údajovej skupiny vydržané parcely podľa registra C KN

Dodatočné kontroly údajovej skupiny vydržané parcely podľa registra C KN (PU-ROEP_VVP) ku kontrole v metodickom návode na spracovanie ROEP pri kontrole údajových riadkov súboru FÚVI

(etapa 1)

Pre FÚVI verzie 2.0 01/96:

- doterajšia parcela sa smie v údajovej skupine PU-ROEP_VVP nachádzať len raz
- doterajšia parcela musí byť zaznamenaná v ISKN
- nová parcela sa smie v údajovej skupine PU-ROEP_VVP nachádzať len raz

Pre FÚVI verzie 4.0 08/03:

- ak je udaná doterajšia parcela, tak musí byť udaná aj odčlenená výmera
- ak je udaná odčlenená výmera, tak musí byť udaná aj doterajšia parcela
- doterajšia parcela sa smie v prípade vydržania nachádzať len raz
- nová parcela sa smie v údajovej skupine PU-ROEP_VVP nachádzať len raz

Kontrola zapísateľnosti údajovej skupiny vydržané parcely podľa registra C KN (PU-ROEP_VVP)

(etapa 3)

- doterajšia parcela musí byť zaznamenaná v ISKN
- ak je nová parcela rovnaká, ako doterajšia parcela, tak sa musí nachádzať v tom istom prípade vydržania
- nová parcela sa musí nachádzať medzi parcelami predmetu konania
- nová parcela nesmie mať napadnuté vlastnícke vzťahy
- nová parcela, ktorá sa nenachádza medzi doterajšími parcelami, nesmie byť zapísaná v ISKN
- ak je udané číslo novej parcely, tak musí byť udaná aj výmera novej parcely
- ak nie je udané číslo novej parcely, tak nesmie byť udaná výmera novej parcely
- pre každé číslo prípadu musí byť uvedená aspoň jedna doterajšia parcela
- pre každé číslo prípadu musí byť uvedená aspoň jedna nová parcela
- Ak je nová vydržaná parcela aj doterajšou parcelou (vydrží sa pod tým istým číslom parcely) a doterajšia parcela je zapísaná na liste vlastníctva, tak parcela musí byť aj parcelou predmetu konania.

Nasledujúce položky sa kontrolujú iba vtedy, ak je udané číslo novej parcely:

- kód druhu pozemku musí zodpovedať osobitnému predpisu
- kód spôsobu využívania pozemku musí zodpovedať osobitnému predpisu
- kód druhu chránenej nehnuteľnosti, ak je udaný, musí zodpovedať osobitnému predpisu
- druh vlastníckeho vzťahu, ak je udaný, musí zodpovedať osobitnému predpisu a nesmie byť rovný 7

Kontrola len pre FÚVI verzie 2.0 01/96:

- pre každé číslo prípadu musí byť súčet výmer nových parciel rovný súčtu výmer doterajších parciel

Kontrola len pre FÚVI verzie 4.0 08/03:

- pre každé číslo prípadu musí byť súčet výmer nových parciel rovný súčtu výmer odčlenených od doterajších parciel
- súčet výmer odčlenených od doterajšej parcely nesmie byť väčší ako výmera parcely v ISKN
- súčet výmer odčlenených od doterajšej parcely, ktorá je aj novou parcelou, musí byť rovný výmere parcely v ISKN
- nová parcela, ktorá je aj doterajšou parcelou a jej nová výmera je menšia ako výmera doterajšej parcely v ISKN musí byť parcelou predmetu konania. (Ak sa z doterajšej parcely má len odčleniť výmera, tak sa má použiť len ako doterajšia parcela, nie ako nová parcela.)


Kontrola zapísateľnosti

Kontrola zapísateľnosti je tretia časť spracovania údajov. Vstupnými údajmi pre túto etapu sú súbory, ktoré sa vytvoria v prvej a druhej etape spracovania a niektoré súbory katastra nehnuteľností.. Pred začiatkom kontroly zapísateľnosti sa kontroluje, či sa vykonala kontrola písomnej časti, kontrola grafickej časti, či sa v nich nevyskytli neprevzateľné chyby a či sa kontrola grafickej časti vykonala až po kontrole písomnej časti.
Kontrolu zapísateľnosti je možné vykonať aj vtedy, ak sa pri kontrole VGI vyskytnú neprevzateľné chyby. Kontrola FÚVI musí byť bez neprevzateľných chýb. Chyby číslo 31003, 31027, 31055, 31057 a 32003 potom môžu byť dôsledkom neprevzateľných chýb pri kontrole VGI, ak pre nejakú parcelu nie je možné vypočítať výmeru, alebo zistiť číslo parcely. Parcely sa v takom prípade nezapíšu do súboru parciel grafickej časti, kde ich hľadá kontrola zapísateľnosti.
Vo formulári Parametre spracovania KU je možné povoliť prekročenie krajnej odchýlky výmer pre C KN, v takom prípade budú chyby číslo 31005, 31025, 31028, 32025 a 32026 chybami prevzateľnými.

V adresári spracovávaného katastrálneho územia KUxxxxxx sa musia nachádzať súbory:

- parciel registra C KN Paxxxxxx.dbf
- parciel registra E KN Epxxxxxx.dbf
- listov vlastníctva Lvxxxxxx.dbf
- vlastníkov Vlxxxxxx.dbf
- právnych vzťahov Pvxxxxxx.dbf a Pvxxxxxx.fpt
- bytových priestorov Bpxxxxxx.dbf
- stavieb na pozemku Csxxxxxx.dbf

- parciel predmetu konania PUxxxxxx_PA.dbf
- vlastníckych vzťahov PUxxxxxx_VV.dbf
- účastníkov právnych vzťahov PUxxxxxx_OSOBA.dbf
- identifikačných častí parciel UO na register C PUxxxxxx_UOSC.dbf

- výmer parciel registra C KN z VGI VYM_KN_xxxxxx.dbf
- výmer parciel UO z VGI VYM_UO_xxxxxx.dbf

Okrem týchto súborov sa spracovávajú aj všetky ostatné súbory s údajmi ROEP, ale tie sa vo vstupných údajoch ROEP nemusia nutne nachádzať:

Kontrola zapísateľnosti sa spúšťa kliknutím na menu Kontrola zapísateľnosti, ktoré je súčasťou menu Cinnosti, ako to znázorňuje nasledujúci obrázok (vľavo v aplikácii WROEP, vpravo WROEP5):

Po skončení behu programu sa objaví - ak sa pri kontrole zistili chyby - okno s počtom prevzateľných a neprevzateľných chýb, alebo oznam o tom, že kontrola skončila bez chyby.
Chyby je možné prezerať vo formulári Zistené chyby Zistené chyby je možné aj vytlačiť v zostave Chyby pri kontrole a spracovaní

Počas kontroly zapísateľnosti sa vytvoria v adresári katastrálneho územia súbory KUxxxxxx_CH_ROEP_ISKN.cdx, KUxxxxxx_CH_ROEP_ISKN.dbf, KUxxxxxx_CHPISGR.cdx , KUxxxxxx_CHPISGR.dbf, KUxxxxxx_OBNOVA_LV.cdx , KUxxxxxx_OBNOVA_LV.dbf, KUxxxxxx_PARC_ODV_ZRUS.dbf, KUxxxxxx_DOT_P_NA_LV.dbf a KUxxxxxx_P_NIE_PREDM_KON.dbf, ktoré používajú v 4. etape - Príprave údajov na zápis do ISKN, kde sa vo formulároch:

- Voľba výmer pre E
- Obnova LV
- Obnova E parciel
- Povolenie zápisu vydržaných parciel, ktoré nie sú predmetom konania
- Povolenie spracovania doterajších parciel, ktoré sú zapísané na liste vlastníctva

určí spracovanie v prípade zistených chýb niektorých druhov.Tieto súbory sa používajú aj v 5. etape spracovania - Zápise ROEP do ISKN. Táto etapa sa však v tejto aplikácii nevykonáva.


Načítanie súboru písomnej časti ROEP

Načítanie a kontrola súboru písomnej časti ROEP

Načítanie súboru písomnej časti ROEP je prvá časť spracovania údajov. Konrolný program skontroluje údaje písomnej časti, ktoré môžu pozostávať z viacerých súborov a správne údaje zapíše do súborov, ktoré sa používajú pri ďalšom spracovaní.
V štartovacom adresári sa musí nachádzať súbor podozrivých mien oa_mena.dbf, ktorý sa na správe katastra používa pri spracovaní ROEP. Ak sa tento súbor v štartovacom adresári nenachádza, tak sa spracovanie nevykoná, čo program oznámi príslušným hlásením. Informáciu o umiestnení súboru písomnej časti ROEP si program vyžiada systémovým oknom na vyhľadanie súborov.
Načítanie a kontrola písomnej časti sa spúšťajú kliknutím na menu Načítanie FÚVI, ktoré je súčasťou menu Cinnosti, ako to znázorňuje nasledujúci obrázok:

Objaví sa formulár, kde treba zadať verziu súboru FÚVI, ktorý sa bude kontrolovať

Po zvolení verzie súboru FÚVI sa objaví systémový formulár na vyhľadávanie súborov, ktorým treba vyhľadať súbor písomnej časti ROEP:

Po vyhľadaní súboru písomnej časti, pričom si aplikácia zaznamená adresár ,kde sa súbor našiel, si program v ďalšom formulári vyžiada zadanie, či sa údaje písomnej časti, ktoré bude kontrolovať, majú pridať k prípadne už prijatým údajom, alebo sa dovtedy prijaté údaje majú vymazať, ako aj kódovú stránku súboru písomnej časti:

Po skončení behu programu sa objaví - ak sa pri kontrole zistili chyby - okno s počtom prevzateľných a neprevzateľných chýb, alebo oznam o tom, že kontrola skončila bez chyby.
Chyby je možné prezerať vo formulári Zistené chyby, ďalšie údaje o behu kontrolného programu sú vidieť vo formulári Evidencia prijatia.
Zistené chyby je možné aj vytlačiť v zostave Chyby pri kontrole a spracovaní


Načítanie a kontrola súborov grafickej časti ROEP

Načítanie súborov grafickej časti ROEP je druhou etapou spracovania údajov.

Vzhľadom na spôsob kontroly údajov ROEP, ktoré sa vyhotovili podľa MN z júla 2006 (FÚVI verzie 5.0 05/06.), je načítanie súborov VGI aj vzhľad menu Činnosti rozdelené na dve časti: Časť A a Časť B. Údaje grafickej časti podľa tohoto metodického návodu obsahujú súbory:

- Stav katastra - KNxxxxxx_k_m.VGI
- Určený operát - UOxxxxxx_k_m.VGI
- Pôvodný určený operát - PMxxxxxx_k_m.VGI
- Hranice areálov BPEJ - BJxxxxxx.VGI
- Vektorový geodetický podklad pre aktualizáciu katastrálnej mapy - VGPxxxxxx_yyyyy.VGI.

kde xxxxxx - číselné označenie katastrálneho územia
k - kód kvality mapy
m - kód mierky mapy

V prípade, že sa vo FÚVI verzie 5.0 05/06 nachádza údajová skupina vydržané parcely, tak sa pre tie prípady vydržania, kde sa nová parcela nenachádza v ISKN, očakávajú súbory VGPxxxxxx_yyyyy.VGI. Pritom je:

- xxxxxx - číselné označenie katastrálneho územia
- yyyyy - číslo prípadu vydržania (možné hodnoty 1 - 99999)

Pritom grafických súborov KN, UO a PM je možné spracovávať viac. Ich názvy musia zodpovedať pokynom ÚGKK SR KO 1528/2004 zo dňa 2.4.2004. Na spracovanie sa vyberú len súbory, ktorých názov je rozšírený o kód kvality a o kód mierky mapy. Súbor BJ a RO (ktorý sa používa v prípade údajov podľa predchádzajúcich metodických návodov) musí mať len pôvodný názov.

V časti A sa načítavajú súbory BJ, KN a PM.VGI, v druhej etape časti B ostatné súbory. Pritom sa ale aj v časti B môžu znova načítať aj súbory KN.VGI, a to v tom prípade, ak sa v prípade spracovania vydržaných parciel nepoužijú súbory VGP.VGI, ale sa vydržania zapracujú priamo do súborov KN.VGI. V časti B nie je možné načítať súčasne súbory KN aj VGP.VGI - príslušný formulár na výber súborov VGI z vybratého adresára to nedovolí.

Ak sa v časti B nenačítajú súbory KN.VGI, tak sa zrušia výsledky načítanie týchto súborov v predchádzajúcom načítaní v časti B. Nezrušia sa, ak sa súbory KN.VGI načítali v časti A, ale len vtedy, ak sa v časti A načítali bezprostredne pred načítaním súborov VGI v časti B. Aktuálny stav načítania súborov je možné vidieť v tlačovej zostave Evidencia prijatia.

Pred opätovným načítaním súborov VGP.VGI sa musia znova načítať súbory KN.VGI.

Údaje grafickej časti podľa predchádzajúcich metodických návodov obsahujú súbory:

- Stav katastra - KNxxxxxx_k_m.VGI
- Určený operát - UOxxxxxx_k_m.VGI
- Identifikácia - ROxxxxxx.VGI
- Hranice areálov BPEJ - BJxxxxxx.VGI

Niektoré chyby, ktoré sa zistia pri kontrole súborov KN.VGI sú v aplikácii s údajmi podľa podľa MN z júla 2006 neprevzateľné, podľa predchádzajúcich MN prevzateľné. Týka sa to najmä chýb porovnávania údajov parciel v súboroch VGI a v písomnej časti údajov katastra nehnuteľností.

V adresári spracovávaného katastrálneho územia KUxxxxxx sa musia nachádzať súbory:

- parciel registra C KN - Paxxxxxx.dbf
- parciel registra E KN - Epxxxxxx.dbf
- parciel predmetu konania - PUxxxxxx_PA.dbf

Kontrolný program údaje grafickej časti skontroluje a vytvorí súbory s výmerami parciel C KN a parciel UO, ktoré sa použijú pri kontrole zapísateľnosti údajov do katastra nehnuteľností.
Načítanie a kontrola grafickej časti sa spúšťa kliknutím na menu Načítanie súborov KN.VGI, príp. Načítanie VGI, ktoré je súčasťou menu Cinnosti, ako to znázorňuje nasledujúci obrázok:

V prípade údajov, ktoré sa vyhotovili podľa MN z júla 2006 (FÚVI verzie 5.0 05/06.), sa napred skontrolujú súbory KN.VGI použitím menu Načítanie súborov KN.VGI a ostatné súbory (pričom sa tu môžu opätovne načítať aj súbory KN.VGI) použitím menu Načítanie VGI.

V prípade údajov podľa predchádzajúcich metodických návodov sa použije len menu Načítanie VGI.

Objaví sa formulár, ktorým sa načítanie a kontrola súborov grafickej časti ROEP riadi:

Kliknutím na tlačítko Adresár sa zobrazí systémový formulár na vyhľadanie adresára, v ktorom sa nachádzajú súbory VGI:

Po kliknutí na tlačítko Select sa v prípade, ak sa v adresári nachádza nejaký súbor VGI pre spracovávané katastrálne územie, zobrazia vo formulári súbory VGI, ktoré sa v ňom nachádzajú:

Ak sa vo vybratom adresári nenachádza žiadny súbor VGI pre spracovávané katastrálne územie, tak sa zobrazí príslušný oznam. Vo formulári je ešte potrebné zadať kódovú stránku súborov a kliknutím na tlačítko Spracovať sa spustí vlastná kontrola súborov, kliknutím na tlačítko Zrušiť sa kontrola zruší. Ak neexistuje súbor UO, tak sa na výpočet výmer použije súbor RO, pričom sa kód kvality a mierka mapy zadá v nasledujúcom formulári:

Vo formulári sa určí kód kvality a mierka mapy. Tieto údaje sa zaznamenajú v súbore výmer parciel UO, v neskoršom spracovaní sa použijú na výpočet krajnej odchýlky. Ak sa formulár opustí tlačítkom Zrušiť, tak sa údaje v súbore nezaznamenajú, do súboru chýb vystúpi neprevzateľná chyba, čo znemožní spracovanie ďalšej etapy.
Aplikácia si zaznamená adresár, kde sa súbory našli, a pri následnej kontrole tento adresár prednastaví.

Po skončení behu programu sa objaví - ak sa pri kontrole zistili chyby - okno s počtom prevzateľných a neprevzateľných chýb, alebo oznam o tom, že kontrola skončila bez chyby.
Chyby je možné prezerať vo formulári Zistené chyby, ďalšie údaje o behu kontrolného programu sú vidieť v tlačovej zostave Evidencia prijatia
Zistené chyby je možné aj vytlačiť v zostave Chyby pri kontrole a spracovaní


Obnova E parciel

Vo formulári Obnova E parciel sa určí pre parcely UO, v ktorých sa líši výmera, druh pozemku alebo umiestnenie v ISKN od údajov v ROEP, či sa údaje v ISKN prepíšu údajmi z ROEP.

Formulár Obnova E parciel sa vyvoláva kliknutím na menu Obnova E parciel, ktoré je súčasťou menu Cinnosti, ako to znázorňuje nasledujúci obrázok:

Objaví sa nasledujúci formulár:

Ak sa prepínač Prepísať pri odlišnej hodnote zapne, tak sa údaj v ISKN prepíše hodnotou z ROEP, ak sa nezapne, tak sa hodnota v ISKN nezmení.


Obnova LV

V tomto formulári sa určí spôsob spracovania listov vlastníctva pre parcely predmetu konania, ktoré sa už vedené v ISKN na liste vlastníctva, ak sa zistili chyby, alebo odchýlky vo vlastníckych vzťahoch.

Formulár obnova LV sa vyvoláva kliknutím na menu Obnova LV, ktoré je súčasťou menu Cinnosti, ako to znázorňuje nasledujúci obrázok:

Objaví sa nasledujúci formulár:

Pre každý list vlastníctva sa vo formulári objaví niektorý z troch možných spôsobov spracovania:

Lv je možné obnoviť | Na liste vlastníctva v ISKN sa nachádzajú len parcely, ktoré patria v ROEP do rovnakej vlastníckej skupiny. Na liste vlastníctva sa len nahradia vlastnícke vzťahy vlastníckymi vzťahmi z ROEP.
Lv nie je možné obnoviť, len rozčleniť a zrušiť | Na tomto liste vlastníctva v ISKN sa nachádzajú parcely, ktoré patria v ROEP do viacerých vlastníckych skupín. Tento list vlastníctva sa rozčlení do toľkých listov vlastníctva, do koľkých vlastníckych skupín patria v ROEP parcely, ktoré sú na ňom zapísané a po rozčlenení sa zruší.
Lv nie je možné obnoviť, len rozčleniť a zvyšok ponechať | Na tomto liste vlastníctva v ISKN sa nachádzajú aj nehnuteľnosti, ktoré nie sú parcelami predmetu konania. Tento list vlastníctva sa rozčlení do toľkých listov vlastníctva, do koľkých vlastníckych skupín patria v ROEP parcely, ktoré sú na ňom zapísané. Po rozčlenení zostanú na pôvodnom liste vlastníctva nehnuteľnosti, ktoré nie sú predmetom konania.

Spracovanie jednotlivých listov vlastníctva je možné ovplyvniť nasledujúcimi prepínačmi:

Zrušiť pôvodné tituly nadobudnutia pri obnove LV | Tento prepínač je prístupný vtedy, ak je LV možné obnoviť. Ak je zapnutý, tak sa pôvodné tituly nadobudnutia zrušia, ak nie je zapnutý, tak pôvodné tituly nadobudnutia na LV zostanú, ale len v tom prípade, ak sa dajú pomocou IČO, alebo rodného čísla priradiť vlastníkom.
Nerozčleňovať LV aj s ďalšími nehnuteľnosťami | Tento prepínač je prístupný vtedy, ak LV nie je možné obnoviť, len rozčleniť a zbytok ponechať a pritom všetky jeho parcely, ktoré sú predmetom konania, patria do jednej vlastníckej skupiny. Ak sa prepínač zapne, tak sa na liste vlastníctva zmenia vlastnícke vzťahy aj tých nehnuteľností, ktoré nie sú predmetom konania.
Preniesť tituly, ťarchy a iné údaje pri rozčlenení | Tento prepínač je prístupný vtedy, ak LV nie je možné obnoviť, len rozčleniť a nezakáže sa rozčlenenie LV. Ak sa prepínač zapne, tak sa na nové LV prenesú okrem parciel aj tituly nadobudnutia, ťarchy a iné údaje, ale len v tom prípade, ak sa dajú pomocou IČO, alebo rodného čísla priradiť vlastníkom.

Do pola s nadpisom Iný údaj, ktorý sa zapíše na LV je možné zapísať iný údaj, ktorý sa zapíše na príslušné LV.

Do pola s napisom Poznámka pre potrebu spracovateľa je možné zapísať poznámky, ktoré sa budú nachádzať len v tomto formulári a nebudú sa zapisovať na LV.

Tlačítkom Vlastnícke vzťahy sa dajú pre listy vlastníctva zobraziť vlastnícke vzťahy. Pre listy vlastníctva, ktoré sa rozčleňujú, sa napred zobrazí formulár vlastníckych skupín na LV:

Pre prípad Lv nie je možné obnoviť, len rozčleniť a zvyšok ponechať a ak sa na LV nachádzajú parcely, ktoré nie sú predmetom konania ( v takomto prípade na LV môžu byť aj iné nehnuteľnosti, nielen parcely), sa napred zobrazia parcely, ktoré na LV po rozčlenení zostanú. Ďalej nasledujú parcely jednotlivých vlastníckych skupín, ktoré sa rozčlenením prepíšu na iné LV. Po nich sa zobrazia ďalšie parcely tejto vlastníckej skupiny, t.j. parcely, ktoré nie sú zapísané na LV, ktoré sa rozčleňuje. Parcely jednej vlastníckej skupiny sa zapíšu na jedno LV. Parcely jednej vlastníckej skupiny sa môžu zapísať aj na viac LV v takom prípade, ak boli parcely, ktorých vlastnícke vzťahy patria do tej istej vlastníckej skupiny už zapísané na rôznych listoch vlastníctva.
V prípade Lv nie je možné obnoviť, len rozčleniť a zrušiť sa zobrazujú len parcely jednotlivých vlastníckych skupín, lebo na LV sa nachádzajú len parcely, ktoré sú predmetom konania a žiadne iné nehnuteľnosti.
Kliknutím na tlačítkoVlastníci, ktoré sa aktivuje po kliknutí na riadok s číslom vlastníckej skupiny, sa zobrazí formulár s vlastníckymi vzťahmi vlastníckej skupiny:

Pre listy vlastníctva s údajom Lv je možné obnoviť sa priamo zobrazia vlastnícke vzťahy, ktorými sa vlastnícke vzťahy na LV obnovia:

Tituly nadobudnutia sa zobrazia len pre parcely, ktoré sa na LV nachádzajú. Po zápise ROEP do ISKN sa zobrazí titul nadobudnutia aj ďalších parciel, ktoré sa na obnovované LV zapísali. V stĺpci pre ťarchy sa zobrazia len ťarchy, ktoré sú v príslušnej údajovej skupine priradené vlastníckemu vzťahu.

V aplikácii pre FÚVI verzie 5.0 05/06 vlastnícke vzťahy obsahujú aj číslo pozemkovoknižnej vložky, poradové číslo zápisu, podlomenie poradového čísla zápisu a poznámku. Číslo pozemkovoknižnej vložky, poradové číslo zápisu a podlomenie poradového čísla zápisu sa zobrazuje v jednom stĺpci, na začiatku údajov je číslo parcely, ktorého sa údaje v danom riadku týkajú. Číslo pozemkovoknižnej vložky je uvedené reťazcom "Pkv:", poradové čislo zápisu reťazcom "Pc:" a podlomenie poradového čísla zápisu reťazcom "Lpc:". V stĺpci pre poznámku je takisto uvedené číslo parcely, ktorého sa poznámka týka:

Po zápise ROEP sa v ISKN môzu vyskytnúť viaceré LV s rovnakými vlastníckymi vzťahmi, ak boli parcely, ktorých vlastnícke vzťahy patria do tej istej vlastníckej skupiny už zapísané na rôznych listoch vlastníctva. Po kliknutí na tlačítko Vlastnícke vzťahy v prípade Lv je možné obnoviť na to upozorní oznam:


Parametre spracovania katastrálneho územia

Formulár sa vyvolávajú kliknutím na rovnomennú časti menu Administrácia, ako to znázorňuje nasledujúci obrázok:

Zobrazí sa formulár:

Vo formulári je možné vyplniť údaje dodávateľa, ktoré sa vytlačia v hlavičke tlačových zostáv. Ak sa tieto údaje nevyplnia, tak zostane hlavička zostáv prázdna.

Pred vykonaním kontroly zapísateľnosti je možné zadať povolenie prekročenia krajnej odchýlky výmer pre C KN. Ak sa prepínač zapne, tak sa budú chyby číslo 31005, 31025, 31028, 32025 a 32026 vyhodnocovať ako prevzateľné, ak sa nezapne, tak ako neprevzateľné.


Parcely registra C katastra nehnuteľností

V tomto formulári je možné prehliadať údaje o parcelách registra C katastra nehnuteľností. Formulár sa vyvoláva z menu Prehliadanie údajov:

Po kliknutí na riadok Parcely registra C sa zobrazí formulár:

V ľavom hornom rohu sú umiestnené navigačné tlačíttka, pomocou ktorých sa postupne zobrazujú záznamy v súbore s údajmi evidencie. Pozícia v súbore je vidieť v údaji Záznam.
V ostatných poliach formulára sú údaje kontroly súborov zodpovedajúce textu uvedenému pred poliami.

V údajoch registra C je možné vyhľadávať kliknutím na tlačítko [image] . Tým sa sprístupnia polia pre číslo parcely, číslo evidenčného listu a číslo listu vlastníctva:

Zadaním hodnoty do niektorého z týchto polí a po jeho opustení sa údaj vyhľadáva. Údaje sa zobrazia zotriedené podľa poľa, ktorého obsah sa použil na vyhľadávanie. Text pred poľom sa zobrazí podčiarknutý, čo označuje spôsob zotriedenia údajov vo formulári.


Parcely registra E katastra nehnuteľností

V tomto formulári je možné prehliadať údaje o parcelách registra E katastra nehnuteľností. Formulár sa vyvoláva z menu Prehliadanie údajov:

Po kliknutí na riadok Parcely registra E sa zobrazí formulár:

V ľavom hornom rohu sú umiestnené navigačné tlačíttka, pomocou ktorých sa postupne zobrazujú záznamy v súbore s údajmi evidencie. Pozícia v súbore je vidieť v údaji Záznam.
V ostatných poliach formulára sú údaje kontroly súborov zodpovedajúce textu uvedenému pred poliami.

V údajoch registra E je možné vyhľadávať kliknutím na tlačítko [image] . Tým sa sprístupnia polia pre číslo parcely a číslo listu vlastníctva:

Zadaním hodnoty do niektorého z týchto polí a po jeho opustení sa údaj vyhľadáva. Údaje sa zobrazia zotriedené podľa poľa, ktorého obsah sa použil na vyhľadávanie. Text pred poľom sa zobrazí podčiarknutý, čo označuje spôsob zotriedenia údajov vo formulári.


Tlačová zostava Parcely účastníka

Táto zostava sa vytvára kliknutím na rovnomenný riadok menu Tlačové zostavy:

Po kliknutí sa zobrazí nasledujúci formulár:

Vo formulári je možné voliť:

- tlač pre všetkých účastníkov
- tlač intervalu účastníkov
- tlač jednotlivých účastníkov

Pre vyššie zvolenú skupinu účastníkov je ešte potrebné zvoliť, či sa bude zostava tlačiť pre známych, alebo pre neznámych účastníkov.

Je možné zvoliť aj triedenie zostavy. Zostava môže byť zotriedená podľa čísla účastníka, alebo podľa názvu / priezviska a mena.

Ďalšou voľbou je možnosť vytvorenia zostavy pre obojstrannú tlač, alebo len jednostrannú tlač. V prípade voľby obojstrannej tlače sa v prípade zostavy pre účastníka s nepárnym počtom strán pridáva na koniec zostavy jedna prázdna strana. Aby sa ale vôbec vytlačila, obsahuje na začiatku riadku bodky, ináč by ju výstupný systém ignoroval. Vlastnú obojstrannú tlač je ale potrebné nastaviť pred tlačou v ovládači tlačiarne.

Zostava sa vytlačí v nasledujúcej štruktúre:

- Znak C na začiatku riadku znamená, že parcela je parcelou registra C, ak je na začiatku riadku UO, tak je parcela parcelou určeného operátu.
- číslo parcely
- položka PU-PKV z údajovej skupiny parcely právneho stavu, alebo položka PU-PKV z údajovej skupiny vlastnícke vzťahy parciel predmetu konania pri FÚVI verzie 5.0 05/06.
- číslo LV z položky KN-CLV v údajovej skupine parcely predmetu konania
- druh pozemku z položky PU-DRP_UO v údajovej skupine parcely predmetu konania
- osobné číslo partnera BSM - údaje partnera BSM sa vytlačia v legende
- vlastnícky podiel z údajovej skupiny vlastnícke vzťahy parciel predmetu konania
- výmera parcely z položky PU-VYM_E v údajovej skupine parcely predmetu konania
- umiestnenie parcely z položky KN_UMP v údajovej skupine parcely predmetu konania
- súčin vlastníckeho podielu a výmery parcely z položky PU-VYM_E v údajovej skupine parcely predmetu konania
- titul nadobudnutia z položky KN-LVB v údajovej skupine vlastnícke vzťahy parciel predmetu konania

V prípade tlače zostavy pre neznámych vlastníkov sa v ďalšom riadku vytlačí správca podľa položky PU-SPR v údajovej skupine vlastnícke vzťahy parciel predmetu konania

Zostavu znázorňuje nasledujúci obrázok:


Práca s aplikáciou

Pri prvom spustení aplikácie je potrebné pomocou formulára výber katastrálneho územia vybrať katastrálne územie, ktoré sa bude spracovávať. Aplikácia si zaznamenáva katastrálne územie, s ktorým sa pracovalo naposledy, takže pri ďalšom spustení sa toto katastrálne územie stane automaticky aktuálnym.
Ďalšie katastrálne územia sa vyberajú takisto pomocou formulára výber katastrálneho územia, alebo ak sa má pracovať s katastrálnym územím, s ktorým sa už pracovalo, tak je ho možné vybrať pomocou formulára aktívne katastrálne územia.

Spracovanie prebieha v nasledujúcich krokoch:

- načítanie a kontrola súboru písomnej časti spracovania ROEP
- načítanie a kontrola súborov grafickej časti ROEP
- kontrola zapísateľnosti
- úprava súboru FÚVI

Po každej etape kontroly je možné chyby prezerať vo formulári Zistené chyby a dajú sa aj prehliadať a vytlačiť v zostave chyby pri kontrole a spracovaní a v zostave početnosť chýb.
Prehľad o prijatých súboroch FÚVI aj VGI poskytuje tlačová zostava evidencia prijatia.

Prehliadať si údaje je možné v nasledujúcich formulároch:

- Údaje ROEP - nehnuteľnosti
- Údaje ROEP - účastníci
- Údaje KN - parcely registra C
- Údaje KN - parcely registra E
- Údaje KN - vlastníci

Okrem týchto formulárov sa používajú formuláre na administrácu a na zadávanie údajov pre tlačové výstupy.


Príprava údajov na zápis do ISKN

Príprava údajov na zápis do ISKN je štvrtá časť spracovania údajov. Vstupnými údajmi pre túto etapu sú súbory, ktoré sa vytvoria v tretej etape spracovania - kontrole zapísateľnosti.

V tejto aplikácii sa - samozrejme - príprava údajov na zápis vykonávať nebude. Táto etapa je v tu zahrnutá len preto, aby bolo možné prezerať, aké údaje sa vo formulároch prípravy na zápis zobrazia.

Kontrola zapísateľnosti sa spúšťa kliknutím na menu Príprava údajov na zápis do ISKN , ktoré je súčasťou menu Cinnosti, ako to znázorňuje nasledujúci obrázok:

Príprava údajov sa vykonáva v troch formulároch:

- Voľba výmer pre E
- Obnova LV
- Obnova E parciel

V týchto formulároch sa určí spracovanie v prípade zistených chýb niektorých druhov.Tieto údaje sa použijú v 5. etape spracovania - Zápise ROEP do ISKN.


Riadenie aplikácie

Aplikácia sa riadi pomocou menu základného formulára aplikácie. , ktoré znázorňuje nasledujúci obrázok.

Aplikáciu je možné ukončiť kliknutím na poslednú položku menu Koniec, alebo na tlačítko [image] základného formulára aplikácie.
Toto tlačítko sa používa na ukončenie aj všetkých ostatných formulárov, ak sa na nich nenachádza tlačítko Zrušiť, alebo Návrat. Ak sa na formulári nachádza tlačítko Zrušiť , alebo Návrat, tak sa po kliknutí na toto tlačítko formulár ukončí bez toho, aby sa vykonala jeho funkcia.


Povolenie spracovania doterajších parciel, ktoré sú zapísané na liste vlastníctva

Doterajšia parcela, ktorá sa celá, alebo čiastočne vydrží by nemala byť zapísaná na liste vlastníctva. Ak je doterajšia parcela zapísaná na liste vlastníctva, tak sa jej spracovanie vo vydržaní musí povoliť v tomto formulári. Do súboru chýb vystúpi za každú parcelu, ktorá sa zobrazí v tomto formulári chyba 31040.

Formulár sa vyvoláva kliknutím na menu Doterajšie parcely, ktoré zapísané na LV, ktoré je súčasťou menu Cinnosti, ako to znázorňuje nasledujúci obrázok:

Objaví sa nasledujúci formulár:

Vo formulári sú údaje parciel, pohybovať sa v nich je možné pomocou navigačných tlačítok, parcelu je možné vyhľadať pomocou vyhľadávacieho tlačítka. Spracovanie parcely sa povolí zapnutím prepínača, ktorý je umiestnený vedľa pola s číslom parcely.


Spustenie aplikácie

Po úspešnej inštalácii sa vytvorí adresár PRG\ROEPDAT , ktorý obsahuje okrem systémového adresára SETUP vlastný program aplikácie ROEPDAT.exe a súbor parametrov config.fpw. Súbor pomocníka Pomoc.chm je potrebné do tohoto adresára presunúť z inštalačného CD.

Štartovací adresár obsahuje ďalej číselníky:

- identifikácia správy katastra - spravakn.idf
- druh pôdy - drp.dbf
- kód chránených nehnuteľností - don.dbf
- typ vlastníkov - tvl.dbf
- register katastrálnych území - rku000.dbf
- register obcí - rob000.dbf
- register okresov - rok000.dbf

a súbory údajov pre úpravu FÚVI:

- položky údajových skupín - pol_skup.dbf a pol_skup.fpt
- údajové skupiny aplikácie - proj_skup.dbf a proj_skup.fpt

Do adresára treba prekopírovať súbor podozrivých mien oa_mena.dbf, ktorý sa používa na správe katastra, pre ktorú sa vytvárajú údaje.

Aplikácia sa spúšťa dvojitým kliknutím na ikonu aplikácie s názvom ROEPDAT v spomínanom adresári ,ako ho znázorňuje nasledujúci obrázok,

alebo na zástupcu [image] , ktorého je možné vytvoriť na ploche.

Pri prvom spustení po nainštalovaní aplikácie, alebo po manipulácii so súborom c_vstup sa zobrazí formulár, kde je potrebné zadať meno používateľa a aktivačný kľúč:

Po zobrazení tohoto formulára je potrebné zatelefonovať na udané telefónne číslo a oznámiť obsah kontrolného kľúča. Dodávateľ aplikácie vygeneruje na základe kontrolného kľúča aktivačný kľúč, ktorý oznámi používateľovi aplikácie. Po zápise do poľa pre aktivačný kľúč a kliknutí na tlačítko O.K. sa aplikácia aktivuje. Ak aktivačný kľúč nebude správny, tak to aplikácia oznámi príslušnym oznamom. Po kliknutí na tlačítko Koniec sa aplikácia ukončí. Na nasledujúcom obrázku je formulár po zadaní požadovaných hodnôt:

Pri prvom spustení aplikácie sa objaví na obrazovke aj nasledujúca otázka:

Po kliknutí na tlačítko Ano sa vytvorí súbor SPRACOVANIE , kde sú uložené riadiace informácie aplikácie, po kliknutí tlačítko Nie sa aplikácia nespustí,na čo upozorní oznamom:

Táto otázka sa môže objaviť aj pri nasledujúcich štartoch aplikácie, ak sa v štartovacom adresári nenachádza súbor SPRACOVANIE, čím by sa ale samozrejme stratili údaje, ktoré sú v ňom uložené, vrátene údaja o aktuálnom katastrálnom území. V takom prípade by sa katastrálne územie vybralo použitím formulára Výber katastrálneho územia.

Po vytvorení súboru SPRACOVANIE sa hľadá súbor identifikácie správy katastra spravakn.idf . Ak sa sa súbor nenajde, tak na to aplikácia upozorní oznamom:

a aplikácia sa nespustí.

Oznamom:

aplikácia informuje o potrebe zvoliť aktuálne katastrálne územie. Aktuálne katastrálne územie sa zvolí použitím formulára Výber katastrálneho územia, alebo Aktívne katastrálne územia.

Spustenie aplikácie pokračuje hľadaním súborov druh pozemkov drp.dbf, druhov vlastníkov tvl.dbf,registra katastrálnych území okresu - rku000.dbf a registra obcí - rob000.dbf v adresároch, ktoré sa nachádzajú v ceste v súbore parametrov config.fpw . Ak sa tam súbory nenachádzajú, tak sa po ozname:

činnosť ukončí. V takom prípade je potrebné v súbore parametrov config.fpw zmeniť cestu na hľadanie súborov.

Po vyhľadaní súborov sa konroluje, či majú zadanú kódovú stránku, ak ju nemajú zadanú, tak sa po ozname:

objaví okno na zadanie kódovej stránky:

Súbory, ktoré sa vytvorili v MS DOS majú kódovú stránku 852, v MS WINDOWS 1250. Ak sa kódová stránka nezadá, tak sa aplikácia nespustí, čo sa oznámi príslušným hlásením.

Po úspešnom ukončení všetkých činností spustenia sa na obrazovke sa objaví základný formulár aplikácie:

V prípade, že sa ešte nevybralo katastrálne územie, tak sú časti menu: Cinnosti , Udaje a Tlačové zostavy neprístupné. Tie sa stanú prístupné až po vybratí katastrálneho územia vo formulári Výber katastrálneho územia.


Súbory aplikácie

Adresáre a súbory aplikácie

Po nainštalovaní aplikácie sa vytvorí - ak používateľ nevyužije možnosť zmeny adresára - adresár PRG\ROEPDAT.

Tento adresár bude po naištalovaní obsahovať systémový adresár SETUP príp. systémový súbor Mscreate.dir, súbor parametrov config.fpw a vlastný aplikačný program ROEPDAT.exe.

Do adresára treba prekopírovať súbor podozrivých mien oa_mena.dbf, ktorý sa použije pri spracovaní ROEP.

V adresári, ktorý sa nachádza v ceste udanej v súbore config.fpw sa musia nachádzať nasledujúce súbory:

- identifikácia správy katastra - spravakn.idf
- druh pôdy - drp.dbf
- kód chránených nehnuteľností - don.dbf
- typ vlastníkov - tvl.dbf
- register katastrálnych území - rku000.dbf
- register obcí - rob000.dbf
- register okresov - rok000.dbf

Ak sa tieto súbory v adresári nenachádzajú, tak program po príslušnom hlásení ukončí svoju činnosť.

V súbore config.fpw musí byť udaná aj cesta do štartovacieho adresára aplikácie - ak používateľ nevyužije možnosť zmeny adresára, tak je to adresár C:\PRG\ROEPDAT.

Počas prvého spustenia aplikácie sa v adresári aplikácie vytvoria súbory SPRACOVANIE.CDX, SPRACOVANIE.DBF a SPRACOVANIE.FPT, kde sa ukladajú informácie o aktuálnom katastrálnom území, ako aj iné údaje.
. Počas procesu aktivácie aplikácie sa v štartovacom adresári aplikácie vytvorí aj súbor c_vstup.dbf a c_vstup.fpt, kde sa ukladajú údaje aktivácie.

V ďalšom texte tejto časti znamená reťazec xxxxxx číselné označenie katastrálneho územia.

Po vybratí katastrálneho územia, ktoré sa má spracovávať, sa vytvorí adresár KUxxxxxx. V adresári sa vytvoria súbory KUxxxxxx_SPRAC.CDX, KUxxxxxxx_SPRAC.DBF a KUxxxxxx_SPRAC.FPT. V týchto súboroch sa ukladajú informácie týkajúce sa spracovania jednotlivých katastrálnych území. Všetky súbory spracovania sa po výbere aktuálneho katastrálneho územia zapisujú do príslušného adresára katastrálneho územia. Ich meno vždy obsahuje aj číselné označenie katastrálneho územia.

Po kontrole súboru FÚVI sa v adresári KUxxxxxx vytvorí súbor KUxxxxxx_CHYBY.DBF a KUxxxxxx_CHYBY.FPT, kde sa zapisujú chyby, ktoré sa zistia pri kontrole. Do tohoto súboru sa zapisujú aj chyby, ktoré sa zistia pri kontrole v 2. a 3. etape.

Ďalej sa vytvoria súbory zodpovedajúce údajovým skupinám, ktoré sa v jednotlivých súboroch FÚVI nachádzajú. Súbory majú názov PUxxxxxx_y, kde y je označenie súboru rovnaké ako posledná časť dohodnutého názvu údajovej skupiny za znakom - resp. _.

Pred 2. etapou - kontrolou grafických súborov - treba do príslušného adresára prekopírovať:

- súbor parciel registra C Paxxxxxx.dbf
- súbor parciel registra E Epxxxxxx.dbf

Počas kontroly grafických súborov sa vytvoria v príslušnom adresári súbory výmer parciel VYM_KN_xxxxxx.cdx, VYM_KN_xxxxxx.dbf, VYM_UO_xxxxxx.cdx a VYM_UO_xxxxxx.dbf.

Pred 3. etapou - kontrolou zapísateľnosti - treba do príslušného adresára prekopírovať:

- súbor listov vlastníctva Lvxxxxxx.dbf
- súbor vlastníkov Vlxxxxxx.dbf
- súbor právnych vzťahov Pvxxxxxx.dbf a Pvxxxxxx.fpt
- súbor bytových priestorov Bpxxxxxx.dbf
- súbor stavieb na pozemku Csxxxxxx.dbf

Počas kontroly zapísateľnosti sa vytvoria v príslušnom adresári súbory KUxxxxxx_CH_ROEP_ISKN.cdx, KUxxxxxx_CH_ROEP_ISKN.dbf, KUxxxxxx_CHPISGR.cdx , CHPISGR_xxxxxx.dbf, KUxxxxxx_OBNOVA_LV.cdx , KUxxxxxx_OBNOVA_LV.dbf, KUxxxxxx_PARC_ODV_ZRUS.dbf a KUxxxxxx_P_NIE_PREDM_KON.dbf, ktoré sa používajú v 4. a 5. etape spracovania. Tieto etapy sa však v tejto aplikácii nevykonávajú.

Úprava súboru FÚVI vyžaduje, aby sa v adresári, ktorý sa nachádza v ceste udanej v súbore config.fpw nachádzali nasledujúce súbory:

- položky údajových skupín - pol_skup.dbf a pol_skup.fpt
- údajové skupiny aplikácie - proj_skup.dbf a proj_skup.fpt

Tieto súbory sa pri inštalácii aplikácie uložia do štartovacieho adresára aplikácie.

Počas úpravy súboru FÚVI sa vytvorí kópia súboru s menom FVxxxxxx_new.txt (ak má pôvodný súbor FÚVI názov FVxxxxxx.txt). Meno sa vytvorí vsunutím reťazca "_new " medzi názov súboru a jeho príponu vrátane znaku bodka. Upravuje sa táto kópia a po skončení úprav sa ňou nahradí originálny súbor a kópia sa odstráni.

V štartovacom adresári sa nachádza aj aplikácia WFPU2DBF.app, ktorá sa používa na vytvorenie katastrálnych súborov DBF/FPT zo znakového súboru KUxxxxxx.FPU.


Tlačová zostava Chyby pri kontrole a spracovaní

Táto zostava sa vytvára kliknutím na rovnomenný riadok menu Tlačové zostavy:

Po kliknutí sa zobrazí formulár, kde sa vyznačí, ktoré chyby sa majú v zostave vytlačiť:

V tejto zostave sa vytlačia chyby, ktoré sa zistia pri kontrole údajov ROEP, tieto je možné prehliadať aj vo formulári Zistené chyby. Riadky zostavy sa tlačia zotriedené podľa mena súboru FÚVI, alebo VGI a čísla riadku.

Pri kontrole údajov ROEP, ktoré sa vyhotovili podľa MN z júla 2006 (FÚVI verzie 5.0 05/06.), sa súbory KN.VGI kontrolujú v časti A a ostatné súbory (vrátane príp. aj súborov KN.VGI) v časti B - bližší popis viď. Načítanie a kontrola súboru grafickej časti ROEP.
Ak sa vykonala kontrola len KN.VGI v časti A, tak sa vo formulári namiesto textu Chyby 2. etapy zobrazí text Chyby časti A.
Ak sa súbory VGI kontrolovali v časti A aj v časti B. tak sa vo formulári namiesto textu Chyby 2. etapy zobrazí text a možnosť voľby podľa nasledujúceho obrázku:

V tomto prípade je súčasne prístupné tlačítko Pokračovať. Ak se nezvolí tlač zostavy pre inú etapu spracovania, tak sa po kliknutí na tlačítko Pokračovať vytlačí zostava chýb podľa nastavenej voľby: buď chyby časti A, alebo 2. etapy časti B.

Ak sa má zostava vytlačiť ako textová zostava do súboru, tak treba zakliknúť voľbu Tlačiť do súboru. Po vytlačení sa zobrazí oznam o umiestnení súboru.

Zostava sa vytlačí v nasledujúcej štruktúre:

- poradie chyby
- kód chyby
- číslo riadku
- Text chyby

Zostavu znázorňuje nasledujúci obrázok:


Tlačová zostava Číselník chýb

Táto zostava sa vytvára kliknutím na rovnomenný riadok menu Tlačové zostavy:

Po kliknutí sa zobrazí nasledujúci formulár:

Vo formulári sa vyznačí, či sa má vytlačiť len text chyby, alebo aj popis chyby. Možné je zvoliť tlač zostavy do súboru, alebo na tlačiareň. V prípade tlače do súboru sa namiesto čiary, ktorá oddeľuje popis chyby od textu chyby vytlačí prázdny riadok.
Ak sa má zostava vytlačiť do súboru, tak treba zakliknúť voľbu Tlačiť do súboru. Po vytlačení sa zobrazí oznam o umiestnení súboru.

Zostava sa vytlačí v nasledujúcej štruktúre:

- kód chyby
- text chyby
- popis chyby

Zostavu znázorňuje nasledujúci obrázok:


Tlačová zostava Evidencia prijatia

Táto zostava sa vytvára kliknutím na rovnomenný riadok menu Tlačové zostavy:

V tejto zostave sa vytlačia údaje o súboroch, ktoré sa načítali a kontrolovali do okamihu vytvárania zostavy. V zostave sú údaje o súboroch FÚVI aj VGI. Údaje o súboroch FÚVI je možné prehliadať aj vo formulári Evidencia prijatia.

Zostavu znázorňuje nasledujúci obrázok:


Parcely s napadnutými vlastníckymi vzťahmi

Táto zostava sa vytvára kliknutím na rovnomenný riadok menu Tlačové zostavy:

V zostave sa vytlačia parcely, ktoré majú napadnuté vlastnícke vzťahy, s ich vlastníckymi vzťahmi. V jednotlivých stĺpcoch zostavy sú čísla napadnutých a napadajúcich vlastníckych vzťahov, vlastník, typ vlastníka, správca a vlastnícky podiel.

Zostavu znázorňuje nasledujúci obrázok:


Tlačová zostava Číselník chýb

Tlačová zostava Parcely zapísané na liste vlastníctva

Táto zostava sa vytvára kliknutím na rovnomenný riadok menu Tlačové zostavy:

Po kliknutí sa zobrazí nasledujúci formulár:

Vo formulári je možné voliť:

- tlač parciel registra C KN, alebo registra E KN
- tlač parciel zapísaných na LV su súčtom vlastníckach podielov nerovným 1, alebo rovným 1
- triedenie zostavy podľa čísla parcely, alebo podľa čísla LV
- tlač na tlačiareň, alebo do súboru
Ak sa má zostava vytlačiť do súboru, tak treba zakliknúť voľbu Tlačiť do súboru. Po vytlačení sa zobrazí oznam o umiestnení súboru.

Zostava sa vytlačí v nasledujúcej štruktúre:

- číslo parcely
- číslo LV
- výmera
- druh pôdy
- súčet vlastníckych podielov

Zostavu znázorňuje nasledujúci obrázok:


Tlačová zostava Početnosť chýb

Táto zostava sa vytvára kliknutím na rovnomenný riadok menu Tlačové zostavy:

Po kliknutí sa zobrazí formulár, kde sa vyznačí, ktoré chyby sa majú v zostave vytlačiť:

V tejto zostave sa vytlačia počty chýb podľa druhu chyby, ktoré sa zistia pri kontrole údajov ROEP.

Pri kontrole údajov ROEP, ktoré sa vyhotovili podľa MN z júla 2006 (FÚVI verzie 5.0 05/06.), sa súbory KN.VGI kontrolujú v časti A a ostatné súbory (vrátane príp. aj súborov KN.VGI) v časti B - bližší popis viď. Načítanie a kontrola súboru grafickej časti ROEP.
Ak sa vykonala kontrola len KN.VGI v časti A, tak sa vo formulári namiesto textu Chyby 2. etapy zobrazí text Chyby časti A.
Ak sa súbory VGI kontrolovali v časti A aj v časti B. tak sa vo formulári namiesto textu Chyby 2. etapy zobrazí text a možnosť voľby podľa nasledujúceho obrázku:

V tomto prípade je súčasne prístupné tlačítko Pokračovať. Ak se nezvolí tlač zostavy pre inú etapu spracovania, tak sa po kliknutí na tlačítko Pokračovať vytlačí zostava chýb podľa nastavenej voľby: buď chyby časti A, alebo 2. etapy časti B.

Ak sa má zostava vytlačiť ako textová zostava do súboru, tak treba zakliknúť voľbu Tlačiť do súboru. Po vytlačení sa zobrazí oznam o umiestnení súboru.

Zostava sa vytlačí v nasledujúcej štruktúre:

- kód chyby
- text chyby
- počet chýb jednotlivých druhov

Na konci zostavy je na ľavej strane počet druhov chýb, na pravej strane je celkový počet chýb pre daný typ zostavy, ktoré sa pri kontrole vyskytli.

Zostavu znázorňuje nasledujúci obrázok:


Tlačové zostavy

Aplikácia vytvára nasledujúce zostavy, ktoré je si možné prehliadať a vytlačiť:

- Chyby pri kontrole a spracovaní
- Početnosť chýb
- Evidencia prijatia
- Číselník chýb
- Parcely zapísané na liste vlastníctva
- Parcely účastníka
- Parcely s napadnutými vlastníckymi vzťahmi

Vo viacerých zostavách je v číslovaní stránok aj celkový počet strán zostavy. Interne to prebieha tak, že sa zostava napred vytvorí do súboru, ktorý sa vymaže, a následne sa zostava vytvára ešte raz. Z toho dôvodu môže trvať vytváranie zostáv relatívne dlho (až desiatky sekúnd) bez známky činnosti programu na obrazovke. Nutným predpokladom je, že tlačiareň je pripojená a zapnutá, ináč program čaká na zapnutie tlačiarne.

Každú zostavu je možné zobraziť pred tlačou na obrazovke, alebo ju priamo tlačiť s možnosťou výberu stránok a nastavenia parametrov tlačiarne. tento výber umožňuje okno:

Po kliknutí na tlačítko Ano sa zobrazí zostava s panelom nástrojov:

ktorý umožňuje stránkovanie v zostave obvyklou sadou navigačných tlačítok. V strede medzi nimi sa nachádza tlačítko [image] umožňujúce nastavenie na stranu podľa jej poradového čísla. Po kliknutí na toto tlačítko sa objaví okno, kde je možné poradové číslo strany zadať.
Kliknutím na tlačítko [image] sa zostava vytlačí, ale vždy len celá zostava, nie je tu možné zadávať tlač vybratých strán, to umožňuje spôsob tlače bez zobrazenia zostavy.
Kliknutím na tlačítko [image] sa zobrazenie zostavy ukončí bez jej tlače.

Po kliknutí na tlačítko Ne okna:

sa zobrazí parametrické okno tlačiarne, kde je možné zadať parametre, ktoré má tlačiareň pri tlači používať a je tu aj možné zadať rozsah strán ktoré sa majú tlačiť. Vzhľad a obsah okna závisí od typu predvolenej tlačiarne.

Po nainštalovani Microsoft Office 2003 je možná voľba výstupu zostavy aj na virtuálnu tlačiareň Microsoft Office Dokument Image Writer:

Po voľbe výstupu na Microsoft Office Dokument Image Writer sa zobrazí systémové okno na zadanie názvu a umiestnenia súboru tlačovej zostavy:

Súbor bude mať príponu mdi. Po dvojitom kliknutí na súbor sa súbor zobrazí v aplikácii Microsoft Office Dokument Imaging , kde ho je možné prezerať, upravovať a vytlačiť. Ak sa má súbor tlačovej zostavy prezerať, alebo tlačiť na počítači s operačným systémom Windows 98, tak ho treba zapísať do súboru formátu tif, čo táto aplikácia umožňuje. Pri tomto spôsobe výstupu tlačovej zostavy ale - žiaľ - nebude súhlasiť celkový počet strán zostavy s počtom, ktorý sa na stránkach zostavy zobrazí.

V záhlaví zostavy sa vytlačia údaje zhotoviteľa podľa údajov vo formulári Parametre spracovania KU. Ak sa vo formulári nezadajú žiadne údaje zhotoviteľa, tak bude hlavička zostáv prázdna.


Účel aplikácie

Aplikácia ROEPDAT je určená na kontrolu a opravu vstupných údajov na konanie o obnove evidencie pozemkov.

Záväznými predpismi, na základe ktorých bola vypracovaná funkčnosť aplikácie sú:

- zákon NR SR č.180/1995 Z.z. - o niektorých opatreniach na usporiadanie vlastníctva k pozemkom
- zákon NR SR č. 419/2002 Z.z. - ktorým sa mení a dopĺňa zákon NR SR č. 180/1995 Z.z.
- Metodický návod na spracovanie registra obnovenej evidencie pozemkov (úplné znenie), máj 2003.
- Metodický návod na spracovanie registra obnovenej evidencie pozemkov (MN 74.20.73.47.00), júl 2006


Formulár Údaje ROEP

Formulár Údaje ROEP - nehnuteľnosti

V tomto formulári je možné prehliadať údajové skupiny súborov písomnej časti ROEP, ktoré sa týkajú nehnuteľností. Formulár sa vyvoláva z menu Prehliadanie údajov:

Po kliknutí na riadok Údaje z ROEP - nehnuteľnosti sa zobrazí formulár:

V ľavom hornom rohu sú umiestnené navigačné tlačítka, pomocou ktorých sa postupne zobrazujú záznamy príslušnej údajovej skupiny. Pozícia v súbore je vidieť v údaji Záznam. Formulár má nasledujúce záložky:

- Parcely predmetu konania
- Parcely právneho stavu - aplikácia pre FÚVI verzie 5.0 05/06 túto záložku neobsahuje
- Vydržané parcely
- Identifikácie UO na C KN
- Zrovnávacie zostavenia
- Súpis parciel predmetu konania

Jednotlivé údajové skupiny sa zobrazia kliknutím na príslušnú záložku formulára s menom údajovej skupiny. Ak sa údajová skupina v údajoch písomnej časti ROEP nenachádza, tak je príslušná záložka neprístupná.

V záložke Parcely predmetu konania a Vydržané parcely je možné kliknutím na tlačítko [image] zobraziť v nasledujúcom formulári vlastníka, alebo spoluvlastníkov parcely. Po kliknutí sa zobrazí formulár, kde je možné zvoliť, či sa vlastnícke vzťahy zobrazia vo forme súpisu, alebo jednotlivo:

Po odpovedi Ano sa vlastnícke vzťahy zobrazia vo forme súpisu:

V aplikácii pre FÚVI verzie 5.0 05/06 vlastnícke vzťahy obsahujú aj číslo pozemkovoknižnej vložky, poradové číslo zápisu, podlomenie poradového čísla zápisu a poznámku :

Ťahom myšou za pravý spodný roh formulára sa mriežka s údajmi zväčšuje, alebo zmenšuje. Šírku stĺpcov je možné meniť, pri nasledujúcom zobrazení formulára sa stĺpce zobrazia v šírke ich predchádzajúceho zobrazenia. Po odpovedi Nie sa vlastnícke vzťahy zobrazia jednotlivo:

V aplikácii pre FÚVI verzie 5.0 05/06 vlastnícke vzťahy obsahujú aj číslo pozemkovoknižnej vložky, poradové číslo zápisu, podlomenie poradového čísla zápisu a poznámku :

V záložke Parcely predmetu konania je možné kliknutím na tlačítko [image] zobraziť v nasledujúcom formulári identifikačné časti parciel UO na register C KN. Po kliknutí sa zobrazí formulár, údaje sa zobrazia vo forme súpisu:

Ťahom myšou za pravý spodný roh formulára sa mriežka s údajmi zväčšuje, alebo zmenšuje.

V záložke Parcely predmetu konania je možné kliknutím na tlačítko [image] zobraziť v nasledujúcom formulári parcely právneho stavu. Po kliknutí sa zobrazí formulár, údaje sa zobrazia vo forme súpisu:

Ťahom myšou za pravý spodný roh formulára sa mriežka s údajmi zväčšuje, alebo zmenšuje.

V záložke Parcely predmetu konania je možné kliknutím na tlačítko [image] vyhľadať parcelu predmetu konania. Číslo parcely C KN, alebo UO, ktorá sa má vyhľadať, je potrebné udať v poliach, ktoré sa nachádzajú vpravo od tlačítka. Ak sa pri vyhľadávaní parcely predmetu konania parcela nenajde, tak sa zobrazí nasledujúci záznam. Nálezy parciel UO sú zotriedené - prvý triediaci kľúč je pôvodné KU, druhý je číslo parcely.

V záložke Parcely právneho stavu je možné kliknutím na tlačítko [image] vyhľadať parcelu právneho stavu. Číslo parcely, ktorá sa má vyhľadať, je potrebné udať v poli, ktoré sa nachádza vpravo od tlačítka:

Ak sa parcela v údajoch údajovej skupiny parcely právneho stavu nenachádza, tak sa hľadá parcela s najbližším vyšším číslom, ale len za týchto podmienok:

- číslo parcely obsahuje len číslice a maximálne jedno lomítko
- číslo parcely je dlhé najviac 9 znakov
- prvý znak nie je lomítko
- číslo parcely obsahuje aj iné číslice ako nuly

Zo zadaného čísla parcely sa použije max. 5 prvých znakov pred lomítkom ako číslo parcely a max. 3 prvé znaky za lomítkom ako podlomenie. Ak číslo neobsahuje lomítko, tak sa použije max. 5 prvých znakov ako číslo parcely.


Formulár Údaje ROEP

Formulár Údaje ROEP - účastníci

V tomto formulári je možné prehliadať údajové skupiny súborov písomnej časti ROEP, ktoré sa týkajú účastníkov. Formulár sa vyvoláva z menu Prehliadanie údajov:

Po kliknutí na riadok Údaje z ROEP - účastníci sa zobrazí formulár:

V ľavom hornom rohu sú umiestnené navigačné tlačítka, pomocou ktorých sa postupne zobrazujú záznamy príslušnej údajovej skupiny. Pozícia v súbore je vidieť v údaji Záznam. Formulár má nasledujúce záložky:

- Účastníci
- Zoznam účastníkov
- Domnelí dedičia - aplikácia pre FÚVI verzie 5.0 05/06 túto záložku neobsahuje

Jednotlivé údajové skupiny sa zobrazia kliknutím na príslušnú záložku formulára s menom údajovej skupiny. Ak sa údajová skupina v údajoch písomnej časti ROEP nenachádza, tak je príslušná záložka neprístupná. V aplikácii pre FÚVI verzie 5.0 05/06 záložky Účastníci a Zoznam účastníkov obsahujú aj položky rodné priezvisko, titul a štát.

V záložke Zoznam účastníkov je možné účastníkov zobraziť kliknutím na názov stĺpca Os. číslo zotriedených podľa osobného čísla a kliknutím na názov stĺpca Názov, Priezvisko, alebo Meno zotriedených podľa reťazca názov /priezvisko + meno:

V záložke Účastníci je možné kliknutím na tlačítko [image] vyhľadať účastníka podľa jeho identifikačného čísla, názvu, priezviska, alebo priezviska a mena. Polia na zadanie údajov, podľa ktorých sa vyhľadávajú účastníci, sa stanú viditeľnými po umiestnení myši nad tlačítko vyhľadávania. Umiestnením myši nad navigačné tlačítka sa polia stanú opäť neviditeľnými. Ak sa vyhľadáva podľa osobného čísla účastníka, tak sa záznamy zobrazia zotriedené podľa osobného čísla, názov položky Osobné číslo je vtedy podčiarknutý. Pti vyhľadávaní podľa názvu, alebo priezviska sa údaje zobrazia zotriedené podľa názvu/priezviska a mena, podčiarknutý je vtedy názov položky Názov / Priezvisko. Ťahom za pravý spodný roh formulára sa menia jeho rozmery. Formulár sa zobrazí vo veľkosti a polohe jeho predchádzajúceho zobrazenia.Tlačítkom [image] je možné zobraziť v nasledujúcom formulári parcely, kde je účastník vlastníkom, alebo spoluvlastníkom. Po kliknutí sa zobrazí formulár, kde je možné zvoliť, či sa vlastnícke vzťahy zobrazia vo forme súpisu, alebo jednotlivo:

Po odpovedi Ano sa vlastnícke vzťahy zobrazia vo forme súpisu:

V aplikácii pre FÚVI verzie 5.0 05/06 vlastnícke vzťahy obsahujú aj číslo pozemkovoknižnej vložky, poradové číslo zápisu, podlomenie poradového čísla zápisu a poznámku :

Ťahom myšou za pravý spodný roh formulára sa mriežka s údajmi zväčšuje, alebo zmenšuje. Po odpovedi Nie sa vlastnícke vzťahy zobrazia jednotlivo:

V aplikácii pre FÚVI verzie 5.0 05/06 vlastnícke vzťahy obsahujú aj číslo pozemkovoknižnej vložky, poradové číslo zápisu, podlomenie poradového čísla zápisu a poznámku :

V záložke Domnelí dedičia je možné kliknutím na tlačítko [image] vyhľadať podľa osobného čísla poručiteľa, alebo domnelého dediča. Po zápise osobného čísla poručiteľa, alebo domnelého dediča sa zobrazí prvý záznam daného osobného čísla. Ďalšie záznamy sa zobrazujú zotriedene podľa osobného čísla poručiteľa, alebo domnelého dediča. Druh zotriedenia udáva podčiarknutie príslušného údaja vo formulári, ako znázorňuje nasledujúci obrázok:


Ukončenie aplikácie

Aplikáciu je možné ukončiť kliknutím na poslednú položku menu:

Koniec, alebo na tlačítko [image] základného formulára aplikácie.


Úprava súboru FÚVI

Systém opráv textového súboru FÚVI je založený na princípe načítania údajového riadku zo súboru FUVI, jeho prevedenie do editačných polí a zápis opraveného riadku do súboru.
Úprava súboru FÚVI sa spúšťa kliknutím na riadok Úprava súboru FÚVI, ktoré je súčasťou menu Cinnosti, ako to znázorňuje nasledujúci obrázok:

Po kliknutí sa zobrazí nasledujúci formulár:

Formulár má nasledujúce ovládacie prvky:

Prepínač Zobrazovať | Kliknutím na príslušnú časť prepínača sa budú zobrazovať všetky, prevzateľné alebo neprevzateľné chyby. Zmena zobrazenia prebehne okamžite po kliknutí myšou na požadovanú predvoľbu.
Tlačidlo Koniec | Ukončí úpravy súboru FUVI.
Tlačidlo Prepočet CRC | Prepočíta stĺpcové a riadkové CRC - kódy celého súboru FÚVI.
Tlačidlo Opraviť riadok | Vyvolá dialóg pre opravu aktuálneho údajového riadku v textovom súbore. V okamihu kliknutia na tlačítko sa načíta príslušný riadok súboru FÚVI. Ak sa súbor nenachádza na tom istom mieste, kde sa nachádzal počas jeho kontroly, tak sa to oznámi príslušným oznamom a oprava sa neuskutoční.

Formulár obsahuje pre každú chybu číslo riadku, kód chyby a popis chyby. V ďalšej časti formulára je názov súboru FÚVI, ktorého chyby sú zobrazené vo formulári. V spodnej časti formulára sa nachádza prípadný bližší popis chyby alebo návod na jej odstránenie.

Oprava aktuálneho riadku

Aktuálny riadok sa opravuje v nasledujúcom formulári, ktorý sa zobrazí po kliknutí na tlačítko Opraviť riadok predchádzajúceho formulára:

Zloženie formulára zodpovedá údajovej skupine riadku súboru FÚVI, ktorý sa opravuje.

Formulár má nasledujúce ovládacie prvky:

Tlačidlo "Pôvodné údaje" | Kliknutím Na toto tlačítko sa do všetkých editačných polí nastavia pôvodné hodnoty.
Spínač "Zobrazovať pôvodný riadok" | Po kliknutí na spínač sa zobrazí alebo skryje formulár s pôvodným riadkom textového súboru FUVI. Obrázok formulára sa nachádza za týmto prehľadom ovládacích prvkov.
Tlačidlo "Opraviť záznam" | Stlačením tohoto tlačítka sa aktuálny riadok uloží do textového súboru. Pritom sa automaticky prepočítajú riadkové aj stĺpcové CRC - kódy celej príslušnej údajovej skupiny.
Tlačidlo "Návrat bez zmien" | Kliknutím na toto tlačítko pustí oprava aktuálneho riadku bez uloženia prípadných zmien v údajoch.

Formulár s pôvodným riadkom textového súboru FUVI:


Vlastníci v katastri nehnuteľností

V tomto formulári je možné prehliadať údaje o vlastníkoch v katastri nehnuteľností. Formulár sa vyvoláva z menu Prehliadanie údajov:

Po kliknutí na riadok Vlastníci sa zobrazí formulár:

V ľavom hornom rohu sú umiestnené navigačné tlačíttka, pomocou ktorých sa postupne zobrazujú záznamy v súbore s údajmi evidencie. Pozícia v súbore je vidieť v údaji Záznam.
V ostatných poliach formulára sú údaje kontroly súborov zodpovedajúce textu uvedenému pred poliami.

V údajoch vlastníkov je možné vyhľadávať kliknutím na tlačítko [image] . Tým sa sprístupnia polia pre číslo listu vlastníctva, ičo/rodné číslo/dátum narodenia, rodné číslo/dátum narodenia BSM a vlastníka:

Zadaním hodnoty do niektorého z týchto polí a po jeho opustení sa údaj vyhľadáva. Ak sa vyhľadáva podľa čísla listu vlastníctva, tak sa vyžaduje aj zadanie poradového čísla spoluvlastníka. Údaje sa zobrazia zotriedené podľa poľa, ktorého obsah sa použil na vyhľadávanie. Text pred poľom sa zobrazí podčiarknutý, čo označuje spôsob zotriedenia údajov vo formulári. Deň a mesiac dátumu treba zadať ako dvojmiestne číslo, v prípade čísla menšieho ako 10 s vedúcou nulou.


Voľba výmer pre E

Formulárom voľba výmer pre E sa pre parcely UO, v ktorých nie je v údajoch ROEP rovnaká písomná a grafická výmera, určí, ktorá z týchto výmer sa zapíše do ISKN.

Formulár voľba výmer pre E sa vyvoláva kliknutím na menu Voľba výmer pre E, ktoré je súčasťou menu Cinnosti, ako to znázorňuje nasledujúci obrázok:

Objaví sa nasledujúci formulár:

Kliknutím do prepínača zvolenej výmery pre jednotlivé parcely sa zvolí na zápis písomná, alebo grafická výmera. Ak sa nezvolila pre niektorú parcelu žiadna výmera, tak sa do ISKN zapíše výmera, ktorá sa určila vo formulári Parametre spracovania KU.


Výber katastrálneho územia

Katastrálne územie, s ktoré sa ešte nepracovávalo, je potrebné vybrať pomocou formulára Výber katastrálneho územia , ak sa s katastrálnym územím už pracovalo, tak je ho možné vybrať aj formulárom Aktívne katastrálne územia. Obidva Formuláre sa vyvolávajú kliknutím na rovnomenné časti menu Administrácia, ako ich znázorňuje nasledujúci obrázok:

Pred vyvolaním formulára Výber katastrálneho územia sa kontroluje, či sa v adresári, ktorý je udaný v súbore config.fpw nachádza register katastrálnych území okresu rku000.dbf. Ak sa tento súbor nenajde, tak sa postupuje rovnako ako pri spustení aplikácie, vrátane kontroly prítomnosti označenia kódovej stránky súboru. Po kontrole súboru sa objaví formulár:

Tlačítko Vybrať sa aktivuje po kliknutí na riadok s názvom katastrálneho územia, ktoré sa má vybrať:

Po kliknutí na tlačítko Vybrať sa napred kontroluje rovnako ,ako pri súbore rku000.dbf, prítomnosť súboru rob000.dbf. Zvolené katastrálne územie stane aktuálnym katastrálnym územím, čo je vidieť v spodnej časti hlavného formulára:

Výber pomocou formulára aktívne katastrálne územia

V tomto formulári sa zobrazia katastrálne územia, s ktorými sa už pracovalo:

Kliknutím na riadok s katastrálnym územím, s ktorým sa má pracovať a na tlačítko Vybrať, ktoré sa týmto aktivuje, sa katastrálne územie vyberie. Vykonajú sa pritom rovnaké kontroly súborov, ako pri výbere katastrálneho územia formulárom výber katastrálnych území.


Vytvorenie katastrálnych súborov DBF/FPT z FÚVI

Táto časť aplikácie je jej voliteľnou súčasťou. Príslušná časť menu je aktívna len vtedy, ak je obsiahnutá v objednávke.
Vytvorenie katastrálnych súborov DBF/FPT z FÚVI sa spúšťa kliknutím na rovnomenné menu, ktoré je súčasťou menu Cinnosti, ako to znázorňuje nasledujúci obrázok:

Objaví sa riadiaci formulár vytvárania súborov. Vo formulári je možné nájsť súbor FÚVI, zvoliť adresár, v ktorom sa súbory vytvoria a zobrazujú sa v ňom informácie o vytvorených súboroch:

Ak sa v aktuálnom adresári spracovania nenachádza súbor FÚVI - KUxxxxxxxx.FPU, kde xxxxxxxx je číslo aktuálneho katastrálneho územia, tak sa súčasne s riadiacim formulárom objaví systémový formulár na vyhľadávanie súborov, ktorým treba vyhľadať súbor FÚVI, z ktorého údajov sa vytvoria katastrálne súbory. Ak by sa vo formulári súbor FÚVI nevybral, tak je ho možné vyvolať znovu kliknutím na tlačítko vedľa pola Súbor FÚVI :

Po vybratí súboru FÚVI a prípadnej zmene výstupného adresára tlačítkom, ktoré je umiestnené vedľa poľa VÝSTUP sa kliknutím na tlačítko Spustiť vytváranie súborov spustí. Po ukončení vytvárania sa vo formulári zobrazia údaje o vytvorených súboroch:

Tlačítkom Pohľad je možné prezerať súbor FÚVI, tlačítkom Nový je možné začať nové vytváranie súborov, tlačítkom Koniec sa aplikácia na vytváranie súborov ukončí.


Zálohovanie súborov

Všetky súbory sa za predpokladu existencie vstupných súborov, ktoré sú potrebné na spracovanie ROEP, dajú opätovným spracovaním príslušného katastrálneho územia vytvoriť znova.

Zálohovať je potrebné nejakým obvyklým spôsobom iba opravovaný súbor FÚVI FVxxxxxx.txt.


Povolenie zápisu vydržaných parciel, ktoré nie sú predmetom konania

Nové vydržané parcely, ktoré sú predmetom konania sa pri zápise do ISKN zapíšu na list vlastníctva podľa ich vlastníckych vzťahov. Ak nová vydržaná parcela nie je predmetom konania, tak sa zapíše do ISKN bez zápisu na list vlastníctva. Keďže ale z údajov ROEP nie je možné zistiť, či parcela nie je predmetom konania v dôsledku chyby údajov, alebo je to parcela, ktorá sa nemá zapísať na list vlastníctva, tak sa zápis takýchto parciel do ISKN musí povoliť v tomto formulári. Vo formulári sa zobrazujú aj parcely, ktoré sú už v ISKN zapísané; pre tieto parcely sa tu povoluje aktualizácia výmery. Do súboru chýb vystúpi za každú parcelu, ktorá sa zobrazí v tomto formulári chyba 31016.

Formulár sa vyvoláva kliknutím na menu Vydržané parcely, ktoré nie sú predmetom konania, ktoré je súčasťou menu Cinnosti, ako to znázorňuje nasledujúci obrázok:

Objaví sa nasledujúci formulár:

Vo formulári sú údaje parciel, pohybovať sa v nich je možné pomocou navigačných tlačítok, parcelu je možné vyhľadať pomocou vyhľadávacieho tlačítka. Zápis parcely sa povolí zapnutím prepínača, ktorý je umiestnený vedľa pola s číslom parcely. Vpravo od prepínača sa zobrazuje zodpovedajúci text t.j. Zapísať, alebo Aktualizovať.